18 июня 2015

DLNA Server на домашнем NAS i-Stor iS607



В качестве НАСа у меня работает уже 4 года i-Stor iS607. Работает замечательно и не требует к себе никакого внимания. Качает торренты, хранит домашнюю библиотеку видео и фотографий. И вот захотелось мне на кухонном телевизоре смотреть не только любимый первый канал, но и скачиваемые моим насом киношки.


Для этого я приобрел бюджетный медиаплеер WD TV Play который не умеет работать с сетевыми шарами, но очень хорошо работает с DLNA сервером.

Нужно сказать что на НАСе у меня установлена прошива RaidSonic + Optware, что позволяет добавить нужные библиотеки и сервисы. За несколько дней экспериментов я остановился на библиотеке mediaromb.

Установка и настройка очень простые:


ipkg install mediatomb


Далее правим файл
/opt/etc/mediatomb.conf



############
MT_OPTIONS="true"
MT_PORT="50500"
MT_USER="root"
MT_GROUP="root"
MT_PIDFILE="/opt/var/run/mediatomb.pid"
MT_LOGFILE="/mnt/ide1/log/mediatomb"
MT_HOME="/opt/etc"
MT_CFGDIR="mediatomb"
############

и файл /opt/etc/default/mediatomb
############
MT_ENABLE=true
############


Запускаем демон
/opt/etc/init.d/S90mediatomb start


Дальше можно отметить через вебинтерфейс http://NASIP:50500 нужные папки и способ их обновления:
Снимок экрана 2014-06-15 в 11.54.01
IMG_20140615_121435

Я так и не смог решить проблему автозапуска демона при загрузке НАСа. Не смотря на наличие скрипта демон не стартует сам. Если кто знает решение, подскажите.


Ссыль:
http://forum.ixbt.com/topic.cgi?id=11:39745
http://www.dd-wrt.com/phpBB2/viewtopic.php?t=80512&sid=5fa704ece828bc5799807e2013fc34e8